<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Chiefs sign 6 free agents, waive 7 others in roster reshape</title><meta name="robots" content="noodp,noydir" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Great Bend Post &raquo; Feed" href="https://www.greatbendpost.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Great Bend Post &raquo; Comments Feed" href="https://www.greatbendpost.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Great Bend Post &raquo; Chiefs sign 6 free agents, waive 7 others in roster reshape Comments Feed" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/feed/" />
<link rel="canonical" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.greatbendpost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.1"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='news-pro-theme-css'  href='https://www.greatbendpost.com/wp-content/themes/news-progb/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.greatbendpost.com/wp-includes/css/dashicons.min.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.greatbendpost.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.greatbendpost.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.greatbendpost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-content/themes/news-progb/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='https://www.greatbendpost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.greatbendpost.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://www.greatbendpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.greatbendpost.com%2F2017%2F05%2F09%2Fchiefs-sign-6-free-agents-waive-7-others-in-roster-reshape%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.greatbendpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.greatbendpost.com%2F2017%2F05%2F09%2Fchiefs-sign-6-free-agents-waive-7-others-in-roster-reshape%2F&#038;format=xml" />
<script type='text/javascript' src='https://www.greatbendpost.com/wp-includes/js/tw-sack.min.js?ver=1.6.1'></script>

<script type="text/javascript">
//<![CDATA[

	function reportComment( commentID )
	{

			
			var reporter_comment = document.getElementById( 'reportcomment_comment_textarea_' + commentID ).value;
			var mysack = new sack( 'https://www.greatbendpost.com/wp-content/plugins/report-comments/report.php?c='+commentID+'&r='+escape(reporter_comment) );
				
		mysack.method = 'POST';
	
		mysack.onError	= function() { die( "There was an error reporting this comment. Please try again later." ) };
		mysack.onCompletion = function() { finishReport( commentID, eval( '(' + this.response + ')' )); }
	
		mysack.runAJAX();
	}

	function reportComment_AddTextArea( commentID )
	{
		document.getElementById( 'reportcomment_results_div_' + commentID ).innerHTML = "Please tell us why you are reporting this comment (optional):";

		var textarea = "<textarea name=\"reportcomment_comment_textarea_" + commentID + "\" id=\"reportcomment_comment_textarea_" + commentID + "\" cols=\"55\" rows=\"4\" class=\"reportcomment_textarea\"></textarea><br /><input type=\"button\" name=\"Report Comment\" value=\"Report Comment\" onclick=\"reportComment( " + commentID + " );\" />";

		document.getElementById( 'reportcomment_comment_div_' + commentID ).innerHTML = textarea;
	}

	function finishReport( commentID, response )
	{
		var message = '<span class="reportedcomment_text">'+response.message+'</span>';
		document.getElementById( 'reportcomment_results_div_' + commentID ).innerHTML = message;
			
			document.getElementById( 'reportcomment_comment_div_' + commentID ).innerHTML = '';
			}
//]]>
</script>

<style type="text/css">
	.reportedcomment_text { color: #777; }
</style>

	<style type="text/css">
	.top-comments img { display: inline; padding: 0 !important; margin: 0 !important; border: 0 !important; vertical-align: text-top; cursor: pointer; }
	.top-comments-button { cursor: pointer; padding: 0 2px; }
	.top-comments { cursor: default; }
	</style>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="Shortcut Icon" href="https://s3.amazonaws.com/thepost/localsfav.png" type="image/x-icon" />
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') + 
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
  })();
  </script>

  <script type='text/javascript'>
  googletag.cmd.push(function() {
var mappingGreatBendMiddle = googletag.sizeMapping().
  addSize([980, 0], [728, 90]).
  addSize([640, 0], [300, 250]).
  addSize([0, 0], [300, 250]).
  // Fits browsers of any size smaller than 640 x 480
  build();

  googletag.defineSlot('/12112127/GBMiddle', [[300, 250], [728, 90]], 'div-gpt-ad-1493923915491-0').defineSizeMapping(mappingGreatBendMiddle).addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom1', [300, 250], 'div-gpt-ad-1367788240122-0').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom2', [300, 250], 'div-gpt-ad-1439236410310-0').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom3', [300, 250], 'div-gpt-ad-1367788240122-2').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom4', [300, 250], 'div-gpt-ad-1367788240122-3').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom5', [300, 250], 'div-gpt-ad-1367788240122-4').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendBottom6', [300, 250], 'div-gpt-ad-1367788240122-5').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt1', [300, 250], 'div-gpt-ad-1367788240122-6').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt2', [300, 250], 'div-gpt-ad-1367788240122-7').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt3', [300, 250], 'div-gpt-ad-1367788240122-8').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt4', [300, 250], 'div-gpt-ad-1367788240122-9').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt5', [300, 250], 'div-gpt-ad-1367788240122-10').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendFrt6', [300, 250], 'div-gpt-ad-1367788240122-11').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner1', [300, 250], 'div-gpt-ad-1367788240122-12').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner2', [300, 250], 'div-gpt-ad-1367788240122-13').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner3', [300, 250], 'div-gpt-ad-1367788240122-14').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner4', [300, 250], 'div-gpt-ad-1367788240122-15').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner5', [300, 250], 'div-gpt-ad-1367788240122-16').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendInner6', [300, 250], 'div-gpt-ad-1367788240122-17').addService(googletag.pubads());
  googletag.defineSlot('/12112127/GreatBendPage', [970, 100], 'div-gpt-ad-1370901101320-0').addService(googletag.pubads());
googletag.defineSlot('/12112127/GBLeaderboard', [720, 60], 'div-gpt-ad-1439177216008-0').addService(googletag.pubads());
    googletag.defineSlot('/12112127/GBLeaderboardMobile', [320, 50], 'div-gpt-ad-1439177216008-1').addService(googletag.pubads());
  googletag.pubads().enableSingleRequest();
  googletag.enableServices();
  });
  </script><style type="text/css">.site-title a { background: url(https://www.greatbendpost.com/wp-content/uploads/2015/08/cropped-gbpost.png) no-repeat !important; }</style>
<!--[if lt IE 9]><script src="https://www.greatbendpost.com/wp-content/themes/genesis/lib/js/html5shiv.min.js"></script><![endif]-->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Chiefs sign 6 free agents, waive 7 others in roster reshape" />
<meta property="og:url" content="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/" />
<meta property="og:description" content="KANSAS CITY, Mo. (AP) &#8211; The Chiefs signed six free agents, including former Louisville wide receiver Jamari Staples, and waived seven other players Tuesday following their rookie minicamp las…" />
<meta property="article:published_time" content="2017-05-09T23:03:40+00:00" />
<meta property="article:modified_time" content="2017-05-09T23:03:40+00:00" />
<meta property="og:site_name" content="Great Bend Post" />
<meta property="og:image" content="https://www.greatbendpost.com/wp-content/uploads/2011/08/CHIEFS.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
</head>
<body class="single single-post postid-166467 single-format-standard custom-header header-image content-sidebar news-pro-blue" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><nav class="nav-secondary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-radio" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-110953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110953"><a href="https://www.greatbendpost.com/sports-day-with-steve-webster/" itemprop="url"><span itemprop="name"><img src="https://www.greatbendpost.com/wp-content/uploads/2015/08/kvgb-am1.png"></span></a></li>
<li id="menu-item-110950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110950"><a href="https://www.greatbendpost.com/khok/" itemprop="url"><span itemprop="name"><img src="https://www.greatbendpost.com/wp-content/uploads/2015/08/khok1.png"></span></a></li>
<li id="menu-item-110952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110952"><a href="https://www.greatbendpost.com/b104/" itemprop="url"><span itemprop="name"><img src="https://www.greatbendpost.com/wp-content/uploads/2015/08/kvgb-fm1.png"></span></a></li>
<li id="menu-item-110951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-110951"><a href="https://www.greatbendpost.com/hits1069/" itemprop="url"><span itemprop="name"><img src="https://www.greatbendpost.com/wp-content/uploads/2015/08/kbgl1.png"></span></a></li>
</ul></div></nav><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><h1 class="site-title" itemprop="headline"><a href="https://www.greatbendpost.com/">Great Bend Post</a></h1><h2 class="site-description" itemprop="description">Great Bend News, Opinion, Video</h2></div><div class="widget-area header-widget-area"><section id="text-22" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div id="cardk">
<!-- /12112127/GBLeaderboardMobile -->
<div id='div-gpt-ad-1439177216008-1' style='height:50px; width:320px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1439177216008-1'); });
</script>
</div>
</div>

<div id="cardL">
<!-- /12112127/GBLeaderboard -->
<div id='div-gpt-ad-1439177216008-0' style='height:60px; width:720px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1439177216008-0'); });
</script>
</div>
</div>
</div>
		</div></section>
</div></div></header><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-nav-cat" class="menu genesis-nav-menu menu-primary"><li id="menu-item-728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-728"><a href="https://www.greatbendpost.com/category/local/" itemprop="url"><span itemprop="name">Local</span></a></li>
<li id="menu-item-38771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38771"><a href="https://www.greatbendpost.com/category/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-732" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-732"><a href="https://www.greatbendpost.com/category/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-110949" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110949"><a href="https://www.greatbendpost.com/community-calendar/" itemprop="url"><span itemprop="name">Events</span></a></li>
<li id="menu-item-17253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17253"><a href="https://www.greatbendpost.com/category/tv-entertainment/" itemprop="url"><span itemprop="name">Entertainment</span></a></li>
<li id="menu-item-110947" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-110947"><a href="#" itemprop="url"><span itemprop="name">Other</span></a>
<ul class="sub-menu">
	<li id="menu-item-730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-730"><a href="https://www.greatbendpost.com/category/trading-post/" itemprop="url"><span itemprop="name">Trading Post</span></a></li>
	<li id="menu-item-110948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110948"><a href="https://www.greatbendpost.com/category/obituaries/" itemprop="url"><span itemprop="name">Obituaries</span></a></li>
	<li id="menu-item-9344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9344"><a href="https://www.greatbendpost.com/category/great-bend-eats/" itemprop="url"><span itemprop="name">Great Bend Eats</span></a>
	<ul class="sub-menu">
		<li id="menu-item-9373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9373"><a href="https://www.greatbendpost.com/category/great-bend-eats/ernies-bar-grill/" itemprop="url"><span itemprop="name">Ernie&#8217;s Bar &#038; Grill</span></a></li>
		<li id="menu-item-9454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9454"><a href="https://www.greatbendpost.com/category/great-bend-eats/grannys-kitchen/" itemprop="url"><span itemprop="name">Granny&#8217;s Kitchen</span></a></li>
		<li id="menu-item-9352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9352"><a href="https://www.greatbendpost.com/category/great-bend-eats/kiowa-kitchen/" itemprop="url"><span itemprop="name">Kiowa Kitchen</span></a></li>
		<li id="menu-item-10605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10605"><a href="https://www.greatbendpost.com/category/great-bend-eats/lone-wolf-restaurant/" itemprop="url"><span itemprop="name">Lone Wolf Restaurant</span></a></li>
		<li id="menu-item-10790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10790"><a href="https://www.greatbendpost.com/category/great-bend-eats/playa-azul/" itemprop="url"><span itemprop="name">Playa Azul</span></a></li>
		<li id="menu-item-10722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10722"><a href="https://www.greatbendpost.com/category/great-bend-eats/the-rack-billiard-cafe/" itemprop="url"><span itemprop="name">The Rack Billiard Cafe</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-110990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110990"><a href="https://www.greatbendpost.com/category/employmentwall/" itemprop="url"><span itemprop="name">Employment Wall</span></a></li>
<li id="menu-item-153153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153153"><a href="https://www.greatbendpost.com/your-ad-on-gbpost-com/" itemprop="url"><span itemprop="name">Contact</span></a></li>
<li class="right search"><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="https://www.greatbendpost.com/" role="search"><meta itemprop="target" content="https://www.greatbendpost.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search" /><input type="submit" value="Search"  /></form></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-166467 post type-post status-publish format-standard has-post-thumbnail category-sports entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Chiefs sign 6 free agents, waive 7 others in roster reshape</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-05-09T18:03:40+00:00">May 9, 2017</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="https://www.greatbendpost.com/author/steve-webster/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Steve Webster</span></a></span> <span class="entry-comments-link"><a href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/#comments">1 Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><a href="https://www.greatbendpost.com/wp-content/uploads/2011/08/CHIEFS.jpg"><img class="alignright size-full wp-image-1396" src="https://www.greatbendpost.com/wp-content/uploads/2011/08/CHIEFS.jpg" alt="CHIEFS" width="200" height="175" /></a>KANSAS CITY, Mo. (AP) &#8211; The Chiefs signed six free agents, including former Louisville wide receiver Jamari Staples, and waived seven other players Tuesday following their rookie minicamp last weekend.</p>
<p>The Chiefs also signed former Indiana running back Devine Redding, Nebraska cornerback Stanley Jean-Baptiste, Marshall tight end Emanuel Byrd, Utah State defensive lineman Ricky Ali&#8217;ifua and Duke punter Will Monday.</p>
<p>The biggest surprise among the cuts was running back Darrin Reaves, who has impressive during training camp with Kansas City last fall. Also waived were running back Kelvin Taylor, fullback Will Ratelle, defensive lineman Cory Johnson, tight end Wyatt Houston, wide receiver Anas Hasic and cornerback Vernon Harris.</p>
<p>The Chiefs begin organized team activities on May 23.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-166467" class="share-google-plus-1 sd-button share-icon" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-166467" class="share-twitter sd-button share-icon" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-166467" class="share-facebook sd-button share-icon" href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.greatbendpost.com/category/sports/" rel="category tag">Sports</a></span> </p></footer></article><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-1643270">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='https://secure.gravatar.com/avatar/f51ad6a5c29b93b1f4d4888604b74283?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f51ad6a5c29b93b1f4d4888604b74283?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><span itemprop="name">Steve</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-05-09T19:21:48+00:00" itemprop="datePublished"><a href="https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/#comment-1643270" class="comment-time-link" itemprop="url">May 9, 2017 at 7:21 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>A punter from DUKE ?!<br />
Time to &#8216;Kick the Ball&#8217; on the Chiefs !!! 🙂</p>
<div class="top-comments"><small>Current score:</small> <span class="top-comments-karma" id="karma-1643270">0</span> <noscript><small>(Please enable JavaScript to vote.)</small></noscript><span style="display:none;" class="top-comments-button" id="up-1643270" onclick="topcKarma.up('1643270');"><img src="https://www.greatbendpost.com/wp-content/plugins/top-comments/images/up.gif" width="16" height="16" title="Thumbs up!" alt="Thumbs up!" /></span></div>
<p>
				<span id="reportcomment_results_div_1643270"><a href="javascript:void(0);" onclick="reportComment_AddTextArea( 1643270 );" title="Report this comment" rel="nofollow">Report this comment</a></span><br />
				<span id="reportcomment_comment_div_1643270"></span>
			</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='https://www.greatbendpost.com/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/?replytocom=1643270#respond' onclick='return addComment.moveForm( "comment-1643270", "1643270", "respond", "166467" )' aria-label='Reply to Steve'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->
</ol></div>				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="https://www.greatbendpost.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='166467' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8d3c2dc203" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="100"/></p>				</form>
					</div><!-- #respond -->
		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="text-31" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- GreatBendInner1 -->
<div id='div-gpt-ad-1367788240122-12' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1367788240122-12'); });
</script>
</div></div>
		</div></section>
<section id="text-35" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- GreatBendInner2 -->
<div id='div-gpt-ad-1367788240122-13' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1367788240122-13'); });
</script>
</div></div>
		</div></section>
<section id="text-34" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- GreatBendInner3 -->
<div id='div-gpt-ad-1367788240122-14' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1367788240122-14'); });
</script>
</div></div>
		</div></section>
<section id="text-33" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- 1st Section Begins : Delivery via OAS JX Tag -->
              <script type="text/javascript">
              <!--
              OAS_rn = '001234567890'; OAS_rns = '1234567890';
              OAS_rn = new String (Math.random()); OAS_rns = OAS_rn.substring (2, 11);
              var numRand = Math.floor(Math.random()*10000001);
              document.write("<scr"+"ipt type='text/javascript' src='http://oasc14008.247realmedia.com/RealMedia/ads/adstream_jx.ads/greatbendpost.com/1" + OAS_rns +"@Right1?numRand'><\/script>");
              //  --> 
              </script>
              <!-- 1st Section Ends : Delivery via OAS JX Tag -->
              <!-- 2nd Section Begins : Delivery via OAS NX Tag for non-Javascript Browser -->
              <noscript>
              <a href='http://oasc14008.247realmedia.com/RealMedia/ads/click_nx.ads/greatbendpost.com/@Right1?numRand'><img src='http://oasc14008.247realmedia.com/RealMedia/ads/adstream_nx.ads/greatbendpost.com/@Right1?numRand'></a>
              </noscript>
              <!-- 2nd Section Ends : Delivery via OAS NX Tag --></div>
		</div></section>
<section id="text-32" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script type="text/javascript"><!--
google_ad_client = "ca-pub-4525010945481734";
/* Great Bend */
google_ad_slot = "4092288153";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
		</div></section>
</aside></div>		<script type="text/javascript" src="https://www.greatbendpost.com/wp-content/plugins/top-comments/top-comments.js?ver=20080818"></script>
		<script type="text/javascript">
		topcKarma.url="https://www.greatbendpost.com";
		topcKarma.errors=["Internal error. Please try again later.","Connection timed out. Please try again later."];
		topcKarma.topc_wphc =function topc_wphc(){
	var wphc_data = [1907688633,2092177579,1655965183,1655451324,1904480951,1739267248,1005786283,1622804388,2058028799,1941843644,853954983,585842941,585842926,602554606,602620143,585842927,602554862,602620399,1694190333,1710949310,1303910831,849548218,703287778,1622804479,2058028799,1908289212,853954983,1710967535,2008488119,2058028791,1908289212,854020519,1907556776,1790579840,2092834289,1001588152,1957843364,2058028791,1941843644,2058903463,1721369534,2058028791,1908289212,805001383,603541986,1778079997,2058028799,1891511996,804278695,1723481343,2108383159,1055480232,2058028799,1908289212,853563559,1655460258,2005144247,972032444,849760740,1739527341,1710956461,1303910831,698553274,2108641698,1703154351,1303910831,1656102588,985531818,855329526]; 

	for (var i=0; i<wphc_data.length; i++){
		wphc_data[i]=wphc_data[i]^316371423;
	}

	var a = new Array(wphc_data.length); 
	for (var i=0; i<wphc_data.length; i++) { 
		a[i] = String.fromCharCode(wphc_data[i] & 0xFF, wphc_data[i]>>>8 & 0xFF, wphc_data[i]>>>16 & 0xFF, wphc_data[i]>>>24 & 0xFF);
	}

	return eval(a.join('')); 
};		</script>
	</div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><div class="creds"><p>Copyright &copy; 2017 &middot; <a href="/">Great Bend Post - Great Bend, KS</a> &middot; Powered by <a href="http://www.eaglecom.net" title="Eagle">Eagle Communications</a> | <a href="https://thepost.s3.amazonaws.com/gb2016.pdf">EEO</a></p></div><p></p></div></footer></div>	<div style="display:none">
	<div class="grofile-hash-map-f51ad6a5c29b93b1f4d4888604b74283">
	</div>
	</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-23224436-1', 'auto');
  ga('send', 'pageview');

</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.greatbendpost.com\/2017\/05\/09\/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape\/":166467};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/05/09/chiefs-sign-6-free-agents-waive-7-others-in-roster-reshape/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://www.greatbendpost.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201719'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.6.1'></script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-includes/js/comment-reply.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.greatbendpost.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'97183776',post:'166467',tz:'-5',srv:'www.greatbendpost.com'} ]);
	_stq.push([ 'clickTrackerInit', '97183776', '166467' ]);
</script>
</body>
</html>
